Gridview rowupdating not working smartboard interactive radioactive dating simulations

Rated 4.19/5 based on 849 customer reviews

I put a breakpoint on the Row Updating event handler and found that the event is not fired. I put a breakpoint on the Row Updating event handler and found that the event is not fired. In the Row Editing function, the edit textboxes appear and I can get the "old" values Then the page renders, I edit the textboxes and hit Update.

Right now, I have not written code for the Update event. Right now, I have not written code for the Update event. Then the page posts back, the text boxes go back to being labels and the new values are lost, and the Row Updating code never fires.

Yes, I did put the breakpoint at the Row Updating line (and not in the function).

You have to make sure that you aren't setting your Grid View's data when it is not postback.

gridview rowupdating not working-43

When I use my user control in an or in an file, Row Updating and the Row Updated events are not at all fired. My user control inherits from "Web Control" and NOT from Grid View PS. I repeated this multiple times and each and everytime I amused myself by seeing the Update button work even without doing anything!

If anybody has an answer for this strange problem, please mail me or reply to this post... the Update button had gone on strike and wasn't raising the Update events for sometime even when the application was in the Edit state. The application was in THE EDIT STATE but still NO UPDATE Events when UPDATE BUTTON WAS FIRED.

I just can't help pulling my hairs out and turning into a complete bald because of this strange problem....

[: D] I got the solution for the invisible problem I was facing in the week! But how will I find out when the control is loaded for the first time? Is Post Back property since a lot many post backs would have happened before loading the control.

Diagnostics; namespace My User Control Heeee yeahhhhhhhh!!! Instead of binding the grid view on every post back, now I am binding the first time the control is loaded!

Leave a Reply